Skip to content
Azure Lessons
Azure Lessons
  • Home
  • AWS
  • Azure
    • Azure Virtual Machine
    • Azure Active Directory
    • Azure CLI
    • Azure CLI Commands List
    • Azure Cognitive Services
    • Azure Cosmos DB
    • Azure DevOps
    • Azure Functions
    • Azure PowerShell Commands
    • Azure Sentinel
    • Azure SQL
    • Azure Storage
    • Azure Synapse
  • Blogs
  • FREE EBOOK

The access level is set to private because anonymous access is disabled on this storage account.

May 6, 2025 by Rajkishore

Recently, I was working on a requirement for one of my projects. I was trying to create a new container inside one of the storage accounts, but the system didn’t allow me to change the access level for the container, and I got the error “The access level is set to private because anonymous access is disabled on this storage account.”

Table of Contents

  • The access level is set to private because anonymous access is disabled on this storage account
  • Solution

The access level is set to private because anonymous access is disabled on this storage account

I will explain the quick steps to fix this error in this tutorial.

I was trying to create a new container, but it didn’t allow me to change the access level, and it is disabled with this error message, as shown in the screenshot below.

The access level is set to private because anonymous access is disabled on this storage account.

Solution

Follow the steps below to fix this error.

  1. Log in to the Azure Portal.
  2. Navigate to the same storage accounts where you wish to create the container.
  3. On the storage account page, expand the settings node, click the Configuration link, select the Enabled option for Allow blob anonymous access, and finally, click the Save button, as shown in the screenshot below.
the access level is set to private because anonymous access is disabled on this storage account

The storage account has been updated successfully, as shown below.

the access level is set to private because anonymous access is disabled

Now, I again tried adding the new container, and this time, I could change the access level successfully, as shown in the screenshot below.

the access level is set to private

You may also like the following articles.

  • VNet Peering
  • How To Create VNet In Azure
  • How to delete Virtual Network in Azure
Microsoft Azure
Rajkishore

I am Rajkishore, and I am a Microsoft Certified IT Consultant. I have over 14 years of experience in Microsoft Azure and AWS, with good experience in Azure Functions, Storage, Virtual Machines, Logic Apps, PowerShell Commands, CLI Commands, Machine Learning, AI, Azure Cognitive Services, DevOps, etc. Not only that, I do have good real-time experience in designing and developing cloud-native data integrations on Azure or AWS, etc. I hope you will learn from these practical Azure tutorials. Read more.

VNet Peering
Azure Function appsettings.json
Subscribe To Our YouTube Channel Subscribe to AzureLessons YouTube Channel

Recent Posts

  • Azure synapse Analytics Tutorial
  • Azure VM Backup Pricing
  • Azure VM
  • What Is Edge Location In AWS
  • DP-300 Certification
  • About Us
  • Contact Us
  • Privacy Policy
  • Sitemap
© 2026 Azure Lessons
Azure
Virtual
Machine
By: Rajkishore
Azure Consultant
PDF

Free 25+ page PDF

Download free Azure Virtual Machine PDF

Download our free 25+ page Azure Virtual Machine guide and master cloud deployment today!

No spam, ever. You will also get new Azure tutorials by email. Unsubscribe any time. Privacy policy

Check your inbox

Your Azure Virtual Machine PDF is on its way to . Can't find it in a few minutes? Look in your Promotions or Spam folder.